Loyalty features not loading on new customer account page

Incident Report for Joy Loyalty

Resolved

This issue has been fully resolved. Joy loyalty features — including Loyalty Hub, rewards, VIP tier benefits, and B2B account details — are now loading correctly on the new customer account page for all merchants. We apologize for any inconvenience this may have caused and thank you for your patience.
Posted May 23, 2026 - 14:35 UTC

Identified

We're aware of an issue where Joy loyalty features (Loyalty Hub, rewards, VIP tier benefits, and B2B account details) may not load on the new customer account page for some merchants. Your storefront widget and admin app are not affected. A fix is being rolled out and we expect full resolution within 24-48 hours. No action needed on your end.
Posted May 23, 2026 - 04:36 UTC
This incident affected: Joy Shopify Extensions.