There has been report about POS extension sometimes does not load customer balance. We are actively investing it.

Incident Report for Joy Loyalty

Monitoring

A fix has been implemented and we are monitoring the results. We updated the POS extension to Shopify latest standard to make sure there is no more disruption
Posted Apr 08, 2026 - 05:14 UTC

Update

We are continuing to investigate this issue.
Posted Apr 03, 2026 - 16:57 UTC

Investigating

We are currently investigating this issue.
Posted Apr 03, 2026 - 16:57 UTC
This incident affects: Joy Shopify Extensions.