Discount Redemption Issue

Incident Report for Joy Loyalty

Resolved

The discount redemption issue has been fully resolved. Customers can now redeem their loyalty points for discounts normally. Thank you for your patience.
Posted Dec 17, 2025 - 02:56 UTC

Monitoring

A fix has been deployed. We are monitoring the system to ensure discount redemption is working correctly for all customers.
Posted Dec 17, 2025 - 02:45 UTC

Identified

We have identified the root cause of the discount redemption issue. Our engineering team is working on a fix.
Posted Dec 17, 2025 - 02:30 UTC

Investigating

We are currently investigating an issue affecting discount redemption. Some customers may experience errors when redeeming points for discount codes.
Posted Dec 17, 2025 - 02:20 UTC